JIRA Client
  1. JIRA Client
  2. JCO-530

Cannot upload changes to issue that was concurrently moved to another project on server

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.1
    • Labels:
    • Planning Category:
      fix (bug fixes, important improvements)
    • Iteration:
      JC-2.1 (Oct 2009)

      Description

      1. Edit issue (change summary), save draft
      2. Go to server and move the issue to another project
      3. Try to upload changes.
      Observe: "JIRA server reported that you have no permission to perform the action (com.atlassian.jira.rpc.exception.RemotePermissionException: This issue does not exist or you don't have permission to view it.). The problem has occurred today at 6:18 PM, used login 'admin'."
      Expected: a way to upload my changes to server.

        Issue Links

          Activity

          Dmitry Peshehonov added a comment -

          After first error from server issue state changes to conflict. But when conflicts are resolved upload fails with:
          "
          Error Updating JIRA

          We have tried to upload data to JIRA using HTML form, but JIRA server responded with the following errors. Please contact support.

          1. Проект и тип запроса совпадают с исходными значениями. The problem has occurred today at 6:22 PM, used login 'admin'.
          "

          Dmitry Peshehonov added a comment -

          Additional problem.
          Issue can be merged to match server values but the application tries to perform empty move after merge.
          1. Add comment. Save locally, dont upload
          2. Move issue on server.
          3. Download changes.
          4. Observe: conflict. Resolve it by taking server values.
          5. Try upload. Observe: error occured - move issue to the same project and type.

          Dmitry Peshehonov added a comment -

          Move conflict now can be resolved but there are some strange steps:
          1. First upload attempt fails with remote error - issue with such key doesnt exists, upload fails. This problem goes away after successful download.
          2. In user change isnt conflicting (comment, link, etc) than issue can be uploaded right after successful download. From user point of view this looks like press "upload" twice, actually first attempt gets new issue key (on download stage) and second just succeeds.
          3. If user change is conflicting (such as summary) than user gets quite a long conflict resolution with many values set to equal locally and remotely. But this step is required to proceed.

          Pavel Zvyagin added a comment -

          I've tried the steps you provide here, and indeed I've got a nasty "Access denied" error trying to upload. And it went away after the issue had been re-downloaded.
          The problem is, it's so damn frightening. I had all your explanations before my eyes, and still. And other users don't, and to them it would look like a pure JIRA Client screw-up. Cannot we make it any friendlier? At least, make a hint in the error explanation that re-downloading might help?

          Dmitry Peshehonov added a comment -

          > I've tried the steps you provide here, and indeed I've got a nasty "Access denied" error trying to upload. And it went away after the issue had been re-downloaded.
          > The problem is, it's so damn frightening. I had all your explanations before my eyes, and still. And other users don't, and to them it would look like a pure JIRA Client screw-up. Cannot we make it any friendlier? At least, make a hint in the error explanation that re-downloading might help?

          The original issue is that user cant resolve conflict with moved issue and has to rollback all changes - loose all data. The problem is now fixed - there is a way to upload changes with out making them again. The way is quite straight forward - try again if you get a confusing error.
          Issue JCO-590 is about more user-friendly processing of such cases.


            People

            • Assignee:
              Dmitry Peshehonov
              Reporter:
              Dmitry Peshehonov
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 3h
                3h
                Remaining:
                Time Spent - 1h 41m Remaining Estimate - 1h 17m
                1h 17m
                Logged:
                Time Spent - 1h 41m Remaining Estimate - 1h 17m Time Not Required
                1h 41m

                  Structure Helper Panel